在线检测未来函数
首页 通达信公式 大智慧公式 同花顺公式 飞狐公式 钱龙公式 公式源码 公式教程 股票知识 股票消息 股票查询

一.三背离主图-经典大智慧公式 背离指标源码

来源:www.gongshi88.com,编辑:炒股公式网,2020-04-15 11:58:20

一.三背离主图-经典大智慧公式 背离指标源码详细说明

炒股公式网(www.gongshi88.com)告诉您:当前正要下载:一.三背离主图-经典大智慧公式 背离指标源码

在网上淘指标算起来已经有数十个。一次次下一次次删,现在留下的已经只有本人认为较好用的几个。现发出来供大家品评。是经典大智慧的:
一.三背离主图
<1>源码
Var1:=EMA(C,3);
Var2:=EMA(C,5);
Var3:=EMA(C,10);
Var4:=EMA(C,20);
Var5:=EMA(C,30);
Var6:=(Var2+Var3+Var4+Var5)/4;
Var7:=(Var6-REF(Var6,15))/REF(Var6,15)*100;
Var8:=(Var6-REF(Var6,15))/REF(Var6, 15)*100;
Var9:=EMA(Var7,8);
STICKLINE(Var7<1*REF(Var7,1),h,l,0.5,0),COLORgray;
STICKLINE(Var7<1*REF(Var7,1),o,c,5, 1),COLORgray;
STICKLINE(Var7>1*REF(Var7,1),h,l,0.5,0),COLOR000999;
STICKLINE(Var7>1*REF(Var7,1),o,c,5, 1),COLOR000999;
STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),h,l,0.5,0),COLORGREEN;{绿-洗盘}
STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),o,c,5, 1),COLORGREEN;
{买进价:=((c-ref(ma(c,6),1))/6+ma(c,6))*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
STICKLINE(买进条件,h,l,0.5,1),colorE66878;
STICKLINE(买进条件,o,c,6,0),colorE66878;
加码价:=((c-ref(ma(c,18),1))/18+ma(c,18))*1.004;
加码条件:=cross(c,加码价) and 加码价>ref(加码价,1);
STICKLINE(加码条件,h,l,0.5,1),colorFF0099;
STICKLINE(加码条件,o,c,6,0),colorFF0099; }
X1:EMA(C,7),color234aaa;
X2:EMA(c,21),coloree00ee;
X3:EMA(X2,21),color999000;
x4:ema(x3,27),color009900;
x5:ema(x2,100),colorFFAA00;
x6:ema(x5,100),color009999;
v1:ema(close,5),color567ee0;
v2:ema(ema(close,29)*1.01,10);
DRAWICON(cross(v1,v2),v2,1);

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
逃 :if(CROSS(84,RSI) , HIGH,high+1),pointdot,linethick7,COLORYELLOW ;high+1,pointdot,linethick7,COLOR000000;
进: if(CROSS(rsi,16) , LOW,LOW-1),pointdot,linethick7,COLORFF00FF ;LOW-1,pointdot,linethick7,COLOR000000;

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWICON(FILTER(B1>0,5),L*0.94,10);
DRAWTEXT(FILTER(B1>0,5),L*0.96,'M底'),COLOR0055ff;{MACD底背离}
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
DRAWICON(FILTER(B2>0,5),L*0.96,10);
DRAWTEXT(FILTER(B2>0,5),L*0.98,'K底'),COLORff00ff;{KDJ底背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWICON(FILTER(B3>0,5),L*0.98,10);
DRAWTEXT(FILTER(B3>0,5),L*0.97,'R底'),COLORyellow;{RSI底背离}
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
DRAWICON(FILTER(D1>0,5),H*1.07,12);
DRAWTEXT(FILTER(D1>0,5),H*1.02,'M顶'),COLORwhite;{MACD顶背离}
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
DRAWICON(FILTER(D2>0,5),H*1.05,12);
DRAWTEXT(FILTER(D2>0,5),H*1.03,'K顶'),COLORf0f000;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
DRAWICON(FILTER(D3>0,5),H*1.03,12),;
DRAWTEXT(FILTER(D3>0,5),H*1.01,'R顶'),COLOR00ff00;{RSI顶背离}

<2>.公式应用
该指标我自己在用时为了更直观做了一点修改,主要是删去了不必要的加码买进信号以将K线色彩调暗,这样图形中就突出了背离信号。用时看到顶底背离还要经过人工确认才可卖出。此图的好处在于提醒我们注意背离信号指导买卖。
下面贴图看一下(刚刚学习贴图不知道能不能成):


  >>>请使用本站搜索功能将找到更多相关一.三背离主图-经典大智慧公式 背离指标源码

标签阅读:

相关文章

钱龙公式更新

钱龙公式热门

股票公式总点击榜

推荐股票公式