在线检测未来函数
首页 通达信公式 大智慧公式 同花顺公式 飞狐公式 钱龙公式 公式源码 公式教程 股票知识 股票消息 股票查询

636公式 公式指标源码

来源:www.gongshi88.com,编辑:炒股公式网,2020-04-15 11:58:06

636公式 公式指标源码详细说明

炒股公式网(www.gongshi88.com)告诉您:当前正要下载:636公式 公式指标源码

636公式
paogu2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
paogu3:=SMA(SMA(paogu2,3,1),3,1);
paogu4:=EMA(paogu3,5);
paogu5:= 3*paogu3-2*paogu4;
paogu6:=hhv(h,250);
paogu7:=llv(l,250);
paogu8:=VOL/MA(VOL,20)>1.5;
paogu9:=if(C>=100,(C+h+l+O)/4,AMOUNT/(V+0.01)/100);
明日阻力:=l+(paogu9-l)+(c-l);
明日支撑:=l+(c-paogu9);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(c>0,paogu6+paogu6,0,10,0),Color000000;
paogu10:=MA(CLOSE,26);
反压线:HHV(FORCAST(C,10),8),coloree8fff,linethick2;
paogu11:= MA(CLOSE,21),linethick0,Color00FFFF;
paogu12:= paogu11+3*STD(C,20),linethick0,Color00FFFF;
paogu13:= paogu11+2*STD(C,20),linethick0,ColorFF00FF;
paogu14:= paogu11-2*STD(C,20),linethick0,ColorF0FF00;
paogu15:= paogu11-2.9*STD(close,20),linethick0,Color00FF00;

M1:ma(c,1);
M5:=MA(c,5),ColorFFFfff;
m8:=ma(c,8);
M10:=MA(c,10),Color00Fff1;
M20:=MA(C,20),Color208fff;
m26:=ma(c,26);
M60:=MA(C,60),Color00ff00;
M125:=MA(C,125),Color00Ffff;
M250:=MA(C,250),Color00ff00;
paogu16:=EMA(C,5),colorff0000;
paogu17:=(REF(paogu16,1));

趋势线:EMA(SLOPE(c,21)*20+c,42) ,colorffffff,linethick2;

paogu18:=cross(paogu16,趋势线);
paogu19:=cross(趋势线,paogu16);
paogu20:=paogu18;
Var111:=IF(DATE>=10201201,0,1);
Var112:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
Var113:=EMA(CLOSE,3);
Var114:=(2*CLOSE+LOW+HIGH)/4*Var111;
Var115:=Var112-Var113;
反弹线:EMA(Var114,40)*0.85,color0000aa;
发财线:EMA(Var114,88)*0.7,color0000cc;



STICKLINE(C<=趋势线 AND C>O,C,O,4,1),COLORffff00;
STICKLINE(C<=趋势线 AND C<=O,C,O,4,1),COLORffff00;
STICKLINE(C<=趋势线 AND C<=O,H,L,0,1),COLORffff00;
STICKLINE(C<=趋势线 AND C>O,C,H,0,1),COLORffff00;
STICKLINE(C<=趋势线 AND C>O,O,L,0,1),COLORffff00;

STICKLINE(C>趋势线AND C>=O,C,O,4,0),COLORred;
STICKLINE(C>趋势线AND C>=O,H,L,0,0),COLORred;
STICKLINE(C>趋势线AND C<O,C,O,4,1),COLORred;
STICKLINE(C>趋势线AND C<O,O,H,0,0),COLORred;
STICKLINE(C>趋势线AND C<O,C,L,0,0),COLORred;




paogu21:=LLV(LOW,21);
paogu22:=(((HIGH + LOW) + CLOSE) / 3);
paogu23:=(paogu22 + (paogu22 - paogu7));
paogu24:=wMA(paogu23,55) ;
paogu25:=IF((paogu23 > paogu24),paogu24,paogu23);
paogu26:=paogu22;
paogu27:=SUM(AMOUNT,5);
paogu28:=DMA(paogu26,(VOL / paogu27));
paogu29:=(((CLOSE - paogu28) / paogu28) * 100);

paogu30:=REF(wMA((((HIGH + LOW) + CLOSE) / 3),3),1);
paogu31:=((((HIGH + LOW) + CLOSE) / 3) > paogu30);
paogu32:=((((HIGH + LOW) + CLOSE) / 3) < paogu30);

EMA120:=EMA(C,120),COLORFFCC66;
EMA250:=EMA(C,250),COLORBLUE;
T1:=EMA(C,30)>EMA(C,60) and EMA(C,60)>EMA(C,90);

paogu33:=COUNT(CROSS(EMA(C,3),EMA(EMA(C,5),5)),2)=1;
paogu34:=COUNT(CROSS(EMA(EMA(C,5),5),EMA(EMA(C,5),5)),2)=1;
paogu35:=FILTER(paogu33 AND paogu34 and t1,2);
paogu36:=paogu35 and EMA(EMA(C,5),5);
ss:=cross(EMA(C,30),EMA(C,60)) AND c>o AND c>REF(C,1)AND C/REF(C,1)>=1.018
or cross(EMA(C,30),EMA120) AND c>o AND c>REF(C,1) AND C/REF(C,1)>=1.018
or cross(EMA(C,60),EMA(C,90)) AND c>o AND c>REF(C,1) AND C/REF(C,1)>=1.018
or cross(EMA(C,30),EMA(C,90)) AND c>o AND c>REF(C,1) AND C/REF(C,1)>=1.018 {AND CROSS(EMA30,EMA120)};
paogu37:=paogu35 and EMA(EMA(C,5),5) and paogu8 ;
paogu38:=CROSS((paogu23 - paogu24),0.16) and paogu8;
paogu39:= MA(CLOSE,1)>趋势线;
paogu40:= CROSS((paogu23 - paogu24),0.16);
paogu41:=MAX(EMA(CLOSE,5),MAX(EMA(CLOSE,10),MAX(EMA(CLOSE,20),EMA(CLOSE,30))));
paogu42:=MIN(EMA(CLOSE,5),MIN(EMA(CLOSE,10),MIN(EMA(CLOSE,20),EMA(CLOSE,30))));
paogu43:=(paogu41-paogu42)/paogu42*1000;
paogu44:=EMA(CLOSE,5)>REF(EMA(CLOSE,5),1) AND EMA(CLOSE,10)>REF(EMA(CLOSE,10),1) AND EMA(CLOSE,20)>REF(EMA(CLOSE,20),1) AND EMA(CLOSE,30)>REF(EMA(CLOSE,30),1) AND EMA(CLOSE,60)>REF(EMA(CLOSE,60),1),linethick0;
paogu45:=paogu43<2,linethick0;
paogu46:=COUNT(paogu45=1,4)>0;
paogu47:=CROSS(EMA(CLOSE,5),EMA(CLOSE,30));
paogu48:=paogu44 AND paogu46 AND paogu47 ;
paogu49:=paogu44 and cross(EMA(CLOSE,5),EMA(CLOSE,10));
paogu50:=(C-MA(C,13))/MA(C,13)*(-100);
paogu51:=REF(paogu50,1)/paogu50>=1.23 AND REF(paogu50,1)>=13 AND C/REF(C,1)>=1.02;
paogu52:=EMA((((H+C)/2+L+(C+L)/2)/3-EMA(LLV(((H+C)/2+L+(C+L)/2)/3,89),2))/(EMA(HHV(((H+C)/2+L+(C+L)/2)/3,21),2)-EMA(LLV(((H+C)/2+L+(C+L)/2)/3,89),2)),8)*100;
paogu53:=SMA(EMA(SMA((C+L)/2,3,1),3),5,1);




paogu54:=CROSS(MA(CLOSE,5),MA(CLOSE,30));
paogu55:=((((WINNER(CLOSE) * 100) - MA((WINNER(CLOSE) * 100),24))) / MA((WINNER(CLOSE) * 100),24)) * 100;
paogu56:=paogu54 AND CLOSE>MA(CLOSE,250);
k:=FILTER(paogu53>REF(paogu53,1)AND HHV(MA((H+C)/2,13),10)<REF(HHV(MA((H+C)/2,13),10),1)AND ((C+L)/2)>REF((C+L)/2,1),5) AND paogu52<88;
paogu100:=paogu54 AND CLOSE>MA(CLOSE,250) and paogu54 AND CLOSE<MA(CLOSE,60);
paogu101:=k and paogu37;
paogu102:=k and paogu38;


paogu110:=paogu54 AND CLOSE<MA(CLOSE,60) and paogu38;
paogu111:=paogu49 and paogu37and paogu39;
paogu112:=paogu47 and k;
paogu113:=paogu47 and paogu44 and cross(EMA(CLOSE,5),EMA(CLOSE,10)) ;
paogu114:=paogu47 and k and cross(EMA(CLOSE,5),EMA(CLOSE,10));

paogu57:=REF((HIGH+LOW+OPEN+2*CLOSE)/5,1);
paogu58:=SMA(MAX((HIGH+LOW+OPEN+2*CLOSE)/5-paogu57,0),10,1)/SMA(ABS((HIGH+LOW+OPEN+2*CLOSE)/5-paogu57),10,1)*100;
paogu59:=IF(COUNT(paogu58<20,5)>=1 AND COUNT((HIGH+LOW+OPEN+2*CLOSE)/5=LLV((HIGH+LOW+OPEN+2*CLOSE)/5,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(paogu59,LOW,'底'),COLORRED;
买入:cross(ma(c,8),ma(c,26))and vol/capital>0.06 and c>open and ma(v,5)>ma(v,10) andv>ma(v,5) and ma(c,26)>ma(c,55) and ma(c,55)> ma(c,110)
;DRAWTEXT(CROSS( ma(c,8),ma(c,26))and c>open and vol/capital>0.06and ma(v,5)>ma(v,10) andv>ma(v,5)and ma(c,26)>ma(c,55) and ma(c,55)> ma(c,110),low,'买入'),coloryellow;
多头:count(ma(c,26)>=ref(ma(c,26),1),6)=6 andcross(ma(c,8),ma(c,26)) andma(c,55)>ma(c,110) and ma(v,5)>ma(v,20);
DRAWTEXT(count(ma(c,26)>=ref(ma(c,26),1),6)=6and cross(ma(c,8),ma(c,26)) andma(c,55)>ma(c,110) and ma(v,5)>ma(v,20), low-0.2,'多头排列') ,coloryellow;
选股:=paogu37 and paogu38 andpaogu8and paogu39;
paogu60:=paogu49 and paogu18;
paogu61:=REF(EMA((o+h+l)/3,4),1);
paogu62:=EMA((o+h+l)/3,4),COLORYELLOW,LINETHICK1;
paogu63:=EMA(c,8);
paogu64:=EMA(c,20);
paogu65:= CROSS(paogu63,paogu64)AND(C>=O)AND paogu62>REF(paogu62,1);
paogu66:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),5,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),5,1)) * 100);
paogu67:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
paogu68:=(HIGH - REF(HIGH,1));
paogu69:=(REF(LOW,1) - LOW);
paogu70:=SUM(IF(((paogu68 > 0) AND (paogu68 > paogu69)),paogu68,0),10);
pagou71:=SUM(IF(((paogu69 > 0) AND (paogu69 > paogu68)),paogu69,0),10);
paogu98:=iF(YEAR>=2007 AND MONTH>=9,0,1);
paogu72:=((paogu70 * 100) / paogu67);
paogu73:=((pagou71 * 100) / paogu67);
paogu74:=MA(((ABS((paogu73 - paogu72)) / (paogu73 + paogu72)) * 100),5);
paogu75:=(paogu66 + paogu74);
paogu76:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
paogu77:=EMA(CLOSE,10);
paogu78:=CROSS(paogu77,paogu76);
paogu79:=paogu20 and paogu36 ;
paogu80:=paogu20 and paogu40 ;
paogu81:=paogu20 and paogu65 ;
paogu82:=paogu20 and paogu78 ;
paogu83:=paogu36 and paogu40 ;
paogu84:=paogu36 and paogu65 ;
paogu85:=paogu36 and paogu78 ;
paogu86:=paogu40 and paogu65 ;
paogu87:=paogu40 and paogu78 ;
paogu88:=paogu65 and paogu78 ;
SW1:= (EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
SW:= DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
ma20:=ma(c,20),colorwhite;
ma120:=ma(c,120),colorffcccc;
ma250:=ma(c,250),colorffcc66;
乖离线:=((c-ref(ma20,1))/20+ma20)*1.20;
tt1:=cross(ma20,ma120)and cross(ma20,ma250) and v>ref(v,1);
tt2:=ma20>ref(ma20,2) and v>ref(v,1) and cross(c,ma20);
紫K:paogu100 or paogu79 orpaogu80 orpaogu81 orpaogu82 orpaogu83 orpaogu84 orpaogu85 orpaogu86 orpaogu87 orpaogu88or paogu101 or paogu102 or paogu110 or paogu111 or paogu112 orpaogu113 or paogu114;
STICKLINE( paogu100 or paogu79 orpaogu80 orpaogu81 orpaogu82 orpaogu83 orpaogu84 orpaogu85 orpaogu86 orpaogu87 orpaogu88or paogu101 or paogu102 or paogu110 or paogu111 or paogu112 orpaogu113 or paogu114
,H,L,0,0),COLORff00ff;
STICKLINE(paogu100 or paogu79 orpaogu80 orpaogu81 orpaogu82 orpaogu83 orpaogu84 orpaogu85 orpaogu86 orpaogu87 orpaogu88or paogu101 or paogu102 or paogu110 or paogu111 or paogu112 orpaogu113 or paogu114
,C,O,6,0),COLORff00ff;
白:=paogu110 or paogu111 or paogu112 or paogu113 or paogu114 or paogu79 orpaogu80 orpaogu81 orpaogu82 orpaogu83 orpaogu84 orpaogu85 orpaogu86 orpaogu87 orpaogu88 ;
白K:白 and sw1>swor ma120>=ref(ma120,1) and cross(c,ma20) and cross(c,ma120) and v>ref(v,1);
STICKLINE(白 andpaogu98 andsw1>sw or ma120>=ref(ma120,1) and cross(c,ma20) and cross(c,ma120) and v>ref(v,1),H,L,0,0),COLORffffff;
STICKLINE(白 andpaogu98 andsw1>swor ma120>=ref(ma120,1) and cross(c,ma20) and cross(c,ma120) and v>ref(v,1),C,O,6,0),COLORffffff;

黄:=paogu79 orpaogu80 orpaogu81 orpaogu82 orpaogu83 orpaogu84 orpaogu85 orpaogu86 orpaogu87 orpaogu88;
黄K:黄andtt2 and sw1>sw;
STICKLINE(黄andtt2 andpaogu98 andsw1>sw,H,L,0,0),COLORYELLOW;
STICKLINE(黄andtt2 andpaogu98 andsw1>sw,C,O,6,0),COLORYELLOW;
s:=llv(c,500);
AA:=YEAR*100+MONTH>199901;BB:=(AA=0)+1;
p1:=(c-ref(c,1))/ref(c,1)*1000;p2:=sum(abs(p1),0); p3:=count(c>0,0); k1:=p2/p3;
a1:=ZIG(3 , 17); aa1:=a1>ref(a1,1); a2:=ZIG(2,17); aa2:=a2<ref(a2,1); K2:=K1*0.8;
b1:=HHVBARS( a1, 30); b2:=LLVBARS(a2 ,30);

X2:DRAWLINE(c=A1*BB and aa1>0,c,B1=10 ,REF(c,B1)-s*2*K1/1400,1),COLOR6666FF,LINETHICK2;

Y3:DRAWLINE(l=A2*AA and aa2>0,L,B2=10 ,REF(l,B2)+s*2*K1/1700*2,1),COLOR6666FF,LINETHICK2;
AA11:=AMOUNT/V;
BB11:=L<AA11*0.9;
CC11:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD11:=L<MA(C,5)*0.921;
EE11:=V<MA(V,5)*1.5;
老鼠仓:BB11 AND CC11 AND DD11 AND EE11,LINETHICK0;
DRAWTEXT(老鼠仓,l*0.99,' 老鼠仓'),COLORYELLOW;
技术总线:紫K or 白K or 黄K or买入 or 多头 ;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
BIAS1W:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
BIAS2W:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
BIAS3W:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
MM:=(((BIAS1W + (2 * BIAS2W)) + (3 * BIAS3W)) / 6);
MN:=MA(MM,3);
VAR1:=((CLOSE * 50) / 100);
VAR2:=(MA(VAR1,30) * 0.83);
VAR3:=MA((VAR1 / VAR2),3);
VV:=VAR3;
DD:=(VAR3 < 1);

VAR1E:=(((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 100);
VAR2E:=SMA(SMA(VAR1E,3,1),3,1);
VAR3E:=EMA(VAR2E,5);
BB1:=VAR3E;
GZ:=((3 * VAR2E) - (2 * VAR3E));
F:=EMA(GZ,3);

VAR1K:=((LOW + HIGH) / 2);
VAR2K:=REF(VAR1K,1);
VAR3K:=((SMA((VAR1K - VAR2K),6,1) / SMA(ABS((VAR1K - VAR2K)),6,1)) * 100);
MMS:=(EMA(VAR3K,1) + 50);
MMM:=EMA(MMS,8);
MML:=EMA(MMS,24);
严重超跌:FILTER((((CLOSE / LOW) > 1.04) AND (COUNT((MN < (0 - 12)),3) >= 1)),15);
DRAWTEXT(FILTER((((CLOSE / LOW) > 1.04) AND (COUNT((MN < (0 - 12)),3) >= 1)),15),high,'严重超跌'),COLORYELLOW;

中级超跌:FILTER((((CLOSE / LOW) > 1.04) AND (COUNT((MN < (0 - 9)),2) >= 1)),15);
DRAWTEXT(FILTER((((CLOSE / LOW) > 1.04) AND (COUNT((MN < (0 - 9)),2) >= 1)),15),low,'中级超跌'),COLORYELLOW;

抢金:FILTER((((COUNT(DD,3) >= 1) AND ((CLOSE / LOW) > 1.04)) AND (CLOSE > REF(CLOSE,1))),10);
DRAWTEXT(FILTER((((COUNT(DD,3) >= 1) AND ((CLOSE / LOW) > 1.04)) AND (CLOSE > REF(CLOSE,1))),10),open,'抢金'),COLORYELLOW;

超跌:FILTER((((CLOSE / LOW) > 1.04) AND (COUNT((MN < (0 - 7)),2) >= 1)),10);
DRAWTEXT(FILTER((((CLOSE / LOW) > 1.04) AND (COUNT((MN < (0 - 7)),2) >= 1)),10),c,'超跌'),COLORYELLOW;


636公式

  >>>请使用本站搜索功能将找到更多相关636公式 公式指标源码

标签阅读:

相关文章

钱龙公式更新

钱龙公式热门

股票公式总点击榜

推荐股票公式