在线检测未来函数
首页 通达信公式 大智慧公式 同花顺公式 飞狐公式 钱龙公式 公式源码 公式教程 股票知识 股票消息 股票查询

变色K线加冷暖通道主图

来源:www.gongshi88.com,编辑:炒股公式网,2020-04-14 17:01:42

变色K线加冷暖通道主图 指标公式:爆发介入点、股王抓涨停主图、天使眼跟踪主图,多空三轨道主图,量柱划线主图:黑牛系统主图黄金分割下降主图。

通达信变色K线加冷暖通道主图指标公式

DRAWBAND(MA(CLOSE,10),RGB(80,0,0),MA(CLOSE,20),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK2;
MA120:MA(CLOSE,120),COLORLIMAGENTA,LINETHICK2;
MA250:MA(CLOSE,250),COLORBLUE,LINETHICK2;
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}
C涨停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
涨停:= IF(ST, C>=C涨停5, C>=C涨停10);
跌停:= IF(ST, C<=C跌停5, C<=C跌停10);
盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);
盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}
STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}
大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);
STICKLINE(大阳线,OPEN,CLOSE,2.5,0),COLORMAGENTA;
大阴线:=C<O AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);
STICKLINE(大阴线,OPEN,CLOSE,2.5,0),COLORCYAN;
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;
假阴:=C<O AND C>REF(C,1);
STICKLINE(假阴,O,C,0.5,0),COLORRED;{假阴柱};
假阳:=C>O AND C<REF(C,1);
STICKLINE(假阳,O,C,0.5,0),COLORGREEN;{假阳柱};

通达信量线量柱擒涨停主图指标公式

DING:=MAX(O,C);{实顶}
DI:=MIN(O,C);{实底}
YANG:=(DI>=REF(DING,1)) OR (C>O AND NOT(DING<=REF(DI,1))) OR (C>REF(C,1) AND C=O) OR (C=REF(C,1) AND C=O AND REF(DING,1)=C);{阳线}
YIN:=NOT(YANG);
{YIN:=(C<O AND NOT(DI>=REF(DING,1))) OR (C>O AND DING<=REF(DI,1)) OR (C<REF(C,1) AND C=O) OR (C=REF(C,1) AND C=O AND REF(DI,1)=C);{阴线}}
YANGSHENG:YANG AND C>=REF(DING,BARSLAST(YIN)) AND (V>REF(V,BARSLAST(YIN)) OR (BETWEEN(V,REF(V,BARSLAST(YIN))*0.95,REF(V,BARSLAST(YIN))*1.05))),NODRAW;
DRAWTEXT(YANGSHENG AND REF(NOT(YANGSHENG),1),L*0.99,'△'),COLORRED;
DRAWTEXT(YANGSHENG AND REF(NOT(YANGSHENG),1) AND V<REF(V,1)*1.5,L*0.99,'▲'),COLORRED;
YINSHENG:=(YIN AND C<=REF(DI,BARSLAST(YANG)) AND V>REF(V,BARSLAST(YANG)));
DRAWTEXT(YINSHENG AND REF(NOT(YINSHENG),1),H*1.02,''),COLORGREEN;
LIANGJIABI:V/C,NODRAW;
MALIANGJIABI:MA(LIANGJIABI,3),NODRAW;
LIANGJIABIXISHU:=1.5;
BLZ:=V>REF(V,1)*1.5;
GLZ:=V=HHV(V,3) AND V=REFX(HHV(V,3),2);
TLZ:=(V*1.1<REFX(V,1) AND REFX(V,1)*1.1<REFX(V,2)) OR (V>REF(V,1)*1.1 AND V*1.1<REFX(V,1)) OR (V>REF(V,1)*1.1 AND REF(V,1)>REF(V,2)*1.1);
JSLS:=C<=REFX(C,1) AND REFX(C,1)<=REFX(C,2) AND LIANGJIABI>REFX(LIANGJIABI,1) AND REFX(LIANGJIABI,1)>REFX(LIANGJIABI,2);
JZ:=BLZ OR GLZ OR TLZ,NODRAW;
JJZ:=CURRBARSCOUNT>=4 AND YANG AND (YANGSHENG) AND JZ AND REFX(LLV(DI,3),3)>=DI AND (REFX(MA(LIANGJIABI,3),3)<=LIANGJIABIXISHU*LIANGJIABI OR REFX(JSLS,1)) AND REFX(C,3)>=DING,NODRAW;
HJZ1:=JJZ AND REFX(MA(C,3),3)>=DING AND REFX(MA(LIANGJIABI,3),3)<=LIANGJIABI AND REFX(YANG,3);
HJZ2:=YANG AND YANGSHENG AND JZ AND REFX(DI,1)>=DI AND REFX(JJZ,2) AND REFX(C,2)>DING AND REFX(LIANGJIABI,1)<LIANGJIABI;
HJZ3:=YANG AND YANGSHENG AND JZ AND REFX(LLV(DI,2),2)>=DI AND REFX(JJZ,3) AND REFX(C,3)>DING AND REFX(MA(LIANGJIABI,2),2)<LIANGJIABI;
HJZ4:=JJZ AND REFX(LLV(DI,3),3)>=DING AND REFX(MA(LIANGJIABI,3),3)<=LIANGJIABI AND REFX(YANG,3) AND (REFX(YANG,1) OR REFX(YANG,2));
WP:JJZ OR HJZ1 OR HJZ4 OR HJZ2 OR HJZ3,NODRAW;
CONDJJZ:=JJZ AND REF(NOT(WP),1);
CONDHJZ1:=(HJZ1 OR HJZ2 OR HJZ3) AND REF(NOT(WP),1);
STICKLINE(CONDJJZ,C,O,1,0),COLORYELLOW;
STICKLINE(CONDHJZ1,C,O,1,0),COLORMAGENTA;
DRAWTEXT(HJZ4 AND REF(NOT(HJZ4),1),L*0.98,'H'),COLORRED;
DRAWLINE(CONDJJZ,DING,REF(CONDJJZ,1),REF(DING,1),1),COLORBROWN;
DRAWLINE(CONDJJZ,DI,REF(CONDJJZ,1),REF(DI,1),1),COLORBROWN;
DRAWLINE(CONDHJZ1,DING,REF(CONDHJZ1,1),REF(DING,1),1),COLORBROWN;
DRAWLINE(CONDHJZ1,DI,REF(CONDHJZ1,1),REF(DI,1),1),COLORBROWN;
Z:=CONDJJZ OR CONDHJZ1;
PZ:=REF(C,BARSLAST(Z));
SHENG:=IF(Z AND C>REF(PZ,1),1,DRAWNULL);
P1DI:=REF(DI,1);
P1L:=REF(L,1);
P2DI:=REF(DI,2);
P2L:=REF(L,2);
P3DI:=REF(DI,3);
P3L:=REF(L,3);
P4DI:=REF(DI,4);
P4L:=REF(L,4);
P5DI:=REF(DI,5);
P5L:=REF(L,5);
P6DI:=REF(DI,6);
P6L:=REF(L,6);
P7DI:=REF(DI,7);
P7L:=REF(L,7);
P8DI:=REF(DI,8);
P8L:=REF(L,8);
P9DI:=REF(DI,9);
P9L:=REF(L,9);
P10DI:=REF(DI,10);
P10L:=REF(L,10);
P11DI:=REF(DI,11);
P11L:=REF(L,11);
P12DI:=REF(DI,12);
P12L:=REF(L,12);
P13DI:=REF(DI,13);
P13L:=REF(L,13);
P14DI:=REF(DI,14);
P14L:=REF(L,14);
P15DI:=REF(DI,15);
P15L:=REF(L,15);
P16DI:=REF(DI,16);
P16L:=REF(L,16);
P17DI:=REF(DI,17);
P17L:=REF(L,17);
P18DI:=REF(DI,18);
P18L:=REF(L,18);
P19DI:=REF(DI,19);
P19L:=REF(L,19);
P20DI:=REF(DI,20);
P20L:=REF(L,20);
JZX1:=ABS(DI-P1DI)<=0.01 OR ABS(DI-P2DI)<=0.01 OR ABS(DI-P3DI)<=0.01 OR ABS(DI-P4DI)<=0.01 OR ABS(DI-P5DI)<=0.01 OR ABS(DI-P6DI)<=0.01 OR ABS(DI-P7DI)<=0.01 OR ABS(DI-P8DI)<=0.01 OR ABS(DI-P9DI)<=0.01 OR ABS(DI-P10DI)<=0.01 OR
ABS(DI-P11DI)<=0.01 OR ABS(DI-P12DI)<=0.01 OR ABS(DI-P13DI)<=0.01 OR ABS(DI-P14DI)<=0.01 OR ABS(DI-P15DI)<=0.01 OR ABS(DI-P16DI)<=0.01 OR ABS(DI-P17DI)<=0.01 OR ABS(DI-P18DI)<=0.01 OR ABS(DI-P19DI)<=0.01 OR ABS(DI-P20DI)<=0.01;
JZX2:=ABS(DI-P1L)<=0.01 OR ABS(DI-P2L)<=0.01 OR ABS(DI-P3L)<=0.01 OR ABS(DI-P4L)<=0.01 OR ABS(DI-P5L)<=0.01 OR ABS(DI-P6L)<=0.01 OR ABS(DI-P7L)<=0.01 OR ABS(DI-P8L)<=0.01 OR ABS(DI-P9L)<=0.01 OR ABS(DI-P10L)<=0.01 OR
ABS(DI-P11L)<=0.01 OR ABS(DI-P12L)<=0.01 OR ABS(DI-P13L)<=0.01 OR ABS(DI-P14L)<=0.01 OR ABS(DI-P15L)<=0.01 OR ABS(DI-P16L)<=0.01 OR ABS(DI-P17L)<=0.01 OR ABS(DI-P18L)<=0.01 OR ABS(DI-P19L)<=0.01 OR ABS(DI-P20L)<=0.01;
JZX3:=ABS(L-P1DI)<=0.01 OR ABS(L-P2DI)<=0.01 OR ABS(L-P3DI)<=0.01 OR ABS(L-P4DI)<=0.01 OR ABS(L-P5DI)<=0.01 OR ABS(L-P6DI)<=0.01 OR ABS(L-P7DI)<=0.01 OR ABS(L-P8DI)<=0.01 OR ABS(L-P9DI)<=0.01 OR ABS(L-P10DI)<=0.01 OR
ABS(L-P11DI)<=0.01 OR ABS(L-P12DI)<=0.01 OR ABS(L-P13DI)<=0.01 OR ABS(L-P14DI)<=0.01 OR ABS(L-P15DI)<=0.01 OR ABS(L-P16DI)<=0.01 OR ABS(L-P17DI)<=0.01 OR ABS(L-P18DI)<=0.01 OR ABS(L-P19DI)<=0.01 OR ABS(L-P20DI)<=0.01;
JZX4:=ABS(L-P1L)<=0.01 OR ABS(L-P2L)<=0.01 OR ABS(L-P3L)<=0.01 OR ABS(L-P4L)<=0.01 OR ABS(L-P5L)<=0.01 OR ABS(L-P6L)<=0.01 OR ABS(L-P7L)<=0.01 OR ABS(L-P8L)<=0.01 OR ABS(L-P9L)<=0.01 OR ABS(L-P10L)<=0.01 OR
ABS(L-P11L)<=0.01 OR ABS(L-P12L)<=0.01 OR ABS(L-P13L)<=0.01 OR ABS(L-P14L)<=0.01 OR ABS(L-P15L)<=0.01 OR ABS(L-P16L)<=0.01 OR ABS(L-P17L)<=0.01 OR ABS(L-P18L)<=0.01 OR ABS(L-P19L)<=0.01 OR ABS(L-P20L)<=0.01;
DRAWTEXT(JZX1 OR JZX2,DI,'+'),COLORWHITE;
DRAWTEXT(JZX3 OR JZX4,L,'+'),COLORWHITE;
P1DING:=REF(DING,1);
P1H:=REF(H,1);
P2DING:=REF(DING,2);
P2H:=REF(H,2);
P3DING:=REF(DING,3);
P3H:=REF(H,3);
P4DING:=REF(DING,4);
P4H:=REF(H,4);
P5DING:=REF(DING,5);
P5H:=REF(H,5);
P6DING:=REF(DING,6);
P6H:=REF(H,6);
P7DING:=REF(DING,7);
P7H:=REF(H,7);
P8DING:=REF(DING,8);
P8H:=REF(H,8);
P9DING:=REF(DING,9);
P9H:=REF(H,9);
P10DING:=REF(DING,10);
P10H:=REF(H,10);
P11DING:=REF(DING,11);
P11H:=REF(H,11);
P12DING:=REF(DING,12);
P12H:=REF(H,12);
P13DING:=REF(DING,13);
P13H:=REF(H,13);
P14DING:=REF(DING,14);
P14H:=REF(H,14);
P15DING:=REF(DING,15);
P15H:=REF(H,15);
P16DING:=REF(DING,16);
P16H:=REF(H,16);
P17DING:=REF(DING,17);
P17H:=REF(H,17);
P18DING:=REF(DING,18);
P18H:=REF(H,18);
P19DING:=REF(DING,19);
P19H:=REF(H,19);
P20DING:=REF(DING,20);
P20H:=REF(H,20);
JZX5:=ABS(DI-P1DING)<=0.01 OR ABS(DI-P2DING)<=0.01 OR ABS(DI-P3DING)<=0.01 OR ABS(DI-P4DING)<=0.01 OR ABS(DI-P5DING)<=0.01 OR ABS(DI-P6DING)<=0.01 OR ABS(DI-P7DING)<=0.01 OR ABS(DI-P8DING)<=0.01 OR ABS(DI-P9DING)<=0.01 OR ABS(DI-P10DING)<=0.01 OR
ABS(DI-P11DING)<=0.01 OR ABS(DI-P12DING)<=0.01 OR ABS(DI-P13DING)<=0.01 OR ABS(DI-P14DING)<=0.01 OR ABS(DI-P15DING)<=0.01 OR ABS(DI-P16DING)<=0.01 OR ABS(DI-P17DING)<=0.01 OR ABS(DI-P18DING)<=0.01 OR ABS(DI-P19DING)<=0.01 OR ABS(DI-P20DING)<=0.01;
JZX6:=ABS(DI-P1H)<=0.01 OR ABS(DI-P2H)<=0.01 OR ABS(DI-P3H)<=0.01 OR ABS(DI-P4H)<=0.01 OR ABS(DI-P5H)<=0.01 OR ABS(DI-P6H)<=0.01 OR ABS(DI-P7H)<=0.01 OR ABS(DI-P8H)<=0.01 OR ABS(DI-P9H)<=0.01 OR ABS(DI-P10H)<=0.01 OR
ABS(DI-P11H)<=0.01 OR ABS(DI-P12H)<=0.01 OR ABS(DI-P13H)<=0.01 OR ABS(DI-P14H)<=0.01 OR ABS(DI-P15H)<=0.01 OR ABS(DI-P16H)<=0.01 OR ABS(DI-P17H)<=0.01 OR ABS(DI-P18H)<=0.01 OR ABS(DI-P19H)<=0.01 OR ABS(DI-P20H)<=0.01;
JZX7:=ABS(L-P1DING)<=0.01 OR ABS(L-P2DING)<=0.01 OR ABS(L-P3DING)<=0.01 OR ABS(L-P4DING)<=0.01 OR ABS(L-P5DING)<=0.01 OR ABS(L-P6DING)<=0.01 OR ABS(L-P7DING)<=0.01 OR ABS(L-P8DING)<=0.01 OR ABS(L-P9DING)<=0.01 OR ABS(L-P10DING)<=0.01 OR
ABS(L-P11DING)<=0.01 OR ABS(L-P12DING)<=0.01 OR ABS(L-P13DING)<=0.01 OR ABS(L-P14DING)<=0.01 OR ABS(L-P15DING)<=0.01 OR ABS(L-P16DING)<=0.01 OR ABS(L-P17DING)<=0.01 OR ABS(L-P18DING)<=0.01 OR ABS(L-P19DING)<=0.01 OR ABS(L-P20DING)<=0.01;
JZX8:=ABS(L-P1H)<=0.01 OR ABS(L-P2H)<=0.01 OR ABS(L-P3H)<=0.01 OR ABS(L-P4H)<=0.01 OR ABS(L-P5H)<=0.01 OR ABS(L-P6H)<=0.01 OR ABS(L-P7H)<=0.01 OR ABS(L-P8H)<=0.01 OR ABS(L-P9H)<=0.01 OR ABS(L-P10H)<=0.01 OR
ABS(L-P11H)<=0.01 OR ABS(L-P12H)<=0.01 OR ABS(L-P13H)<=0.01 OR ABS(L-P14H)<=0.01 OR ABS(L-P15H)<=0.01 OR ABS(L-P16H)<=0.01 OR ABS(L-P17H)<=0.01 OR ABS(L-P18H)<=0.01 OR ABS(L-P19H)<=0.01 OR ABS(L-P20H)<=0.01;
DRAWTEXT(JZX5 OR JZX6,DI,' +'),COLORYELLOW;
DRAWTEXT(JZX7 OR JZX8,L,' +'),COLORYELLOW;

3121刻度主图鳄鱼嘴主图及选股,财神大道主图、智能买卖操盘线主图,多空通道主图白柱买进主图,起爆大主图。

标签阅读:

相关文章

股票公式源码更新

股票公式源码热门

股票公式总点击榜

推荐股票公式