在线检测未来函数
首页 通达信公式 大智慧公式 同花顺公式 飞狐公式 钱龙公式 公式源码 公式教程 股票知识 股票消息 股票查询

最新财务分析副图(大智慧)

来源:www.gongshi88.com,编辑:炒股公式网,2020-04-13 17:05:17

源码奉上:但可能需要机构版的支持,因为一般免费的大智慧也能用,但有些关键财务数据为0,希望高手予以解决:

DRAWGBKLAST(CLOSE>0, STRIP(RGB(10,10,10),RGB(50,15,8),0));
X:=DATE<1091231;
DRAWTEXTABS(10,10,'所属板块:'+BKNAME),LINETHICK2,COLOR0000FF;
DD:=FINANCE2(35)*X;
SS:=FINANCE2(37)*X;
GG:=(FINANCE2(33)/FINANCE2(35))/10*X;
HH:=DYNAINFO(39)*X;
DRAWTEXTABS(10,28,'总股本:'+NUMTOSTRN(DD,0)+'万'+'.流通A股:'+NUMTOSTRN(SS,0)
+'万'+'.人均持股:'+CEILING(CAPITAL*100/EXTRADATA('散户线'))+'.市盈率:'
+NUMTOSTRN(HH,2)+''+'.每股收益:'+NUMTOSTRN(GG,3)),LINETHICK2,COLORWHITE;
DRAWTEXTABS(10,100,'机构评级:'+EXTRASTRING('评级')),LINETHICK2,COLOR8285FF;
流通市值:=C*CAPITAL*VOLUNIT/100000000;
市净率:=DYNAINFO(58);
F:=COST(5 );
J:=COST(95 );
M:=COST(15 );
N:=COST(85 );
F1:=(J-F)/(F+J)*100;
M1:=(N-M)/(N+M)*100;
成本集中度:=F1;
莸利比例:=WINNER(C )*100;
日换手率:=VOL/CAPITAL*100;
净资产:=FINANCE2(4)*X;
每股公积金:=FINANCE2(7)*X;
每股未分配:=FINANCE2(8)*X;
股东权益比:=FINANCE2(9)*X;
主营同比:=FINANCE2(11)*X;
净利润同比:=FINANCE2(10)*X;
净资收益率:=FINANCE2(5)*X;
毛利润率:=FINANCE2(12)*X;
现金流:=FINANCE2(6)*X;
现金比:=FINANCE2(23)/FINANCE2(14)*100;
负债比:=FINANCE2(20)/FINANCE2(14)*100;
DRAWTEXTABS(10,46,'流通市值:'+流通市值+' '),LINETHICK2,COLORFF00FF;
DRAWTEXTABS(140,46,'市净率:'+市净率+' '),LINETHICK2,COLORFF00FF;
DRAWTEXTABS(280,46,'成本集中度:'+成本集中度+'% '),LINETHICK2,COLORFF00FF;
DRAWTEXTABS(420,46,'莸利比例:'+莸利比例+'% '),LINETHICK2,COLORFF00FF;
DRAWTEXTABS(560,46,'日换手率:'+日换手率+'% '),LINETHICK2,COLORFF00FF;
DRAWTEXTABS(10,64,'净资产:'+净资产+'元 '),LINETHICK2,COLORGREEN;
DRAWTEXTABS(140,64,'每股公积金:'+每股公积金+'元 '),LINETHICK2,COLORGREEN;
DRAWTEXTABS(280,64,'每股未分配:'+每股未分配+'元 '),LINETHICK2,COLORGREEN;
DRAWTEXTABS(420,64,'股东权益比:'+股东权益比+'% '),LINETHICK2,COLORGREEN;
DRAWTEXTABS(560,64,'负债比:'+负债比+'% '),LINETHICK2,COLORGREEN;
DRAWTEXTABS(10,82,'主营同比:'+主营同比+'% '),LINETHICK2,COLOR00FFFF;
DRAWTEXTABS(140,82,'净利润同比:'+净利润同比+'% '),LINETHICK2,COLOR00FFFF;
DRAWTEXTABS(280,82,'净资收益率:'+净资收益率+'% '),LINETHICK2,COLOR00FFFF;
DRAWTEXTABS(420,82,'毛利润率:'+毛利润率+'% '),LINETHICK2,COLOR00FFFF;
DRAWTEXTABS(560,82,'现金流:'+现金流+'元 '),LINETHICK2,COLOR00FFFF;
DRAWTEXTABS(660,82,'现金比:'+现金比+'% '),LINETHICK2,COLOR00FFFF;
GJ:=IF(C=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(V+0.01)/100);
TT1:='今日成交量大于昨日,且有继续增大趋势';
TT2:='今日成交量小于昨日,但有放大迹象';
TT3:='今日成交量大于昨日, 但有缩小迹象';
TT4:='今日成交量小于昨日,且有缩小迹象';
TT:=IFS(BARSTATUS=2 AND V>REF(V,1) AND MA(V,5)>REF(MA(V,5),1),TT1,IFS(BARSTATUS=2 AND V<REF(V,1) AND MA(V,5)>REF(MA(V,5),1),TT2
,IFS(BARSTATUS=2 AND V>REF(V,1)AND MA(V,5)<REF(MA(V,5),1),TT3,TT4)));
DRAWTEXTABS(460,100,TT),LINETHICK2,COLOR8285FF;
DRAWTEXTABS(10,120,'告诫朋友:指标是参考,决策在人脑.'),LINETHICK2,COLOR0088FF;
DRAWTEXTABS(10,140,'定位准确,思路清晰.'),LINETHICK2,COLOR0088FF;

 

最新财务分析副图(大智慧)的选股公式如下:

标签阅读:

相关文章

大智慧公式更新

大智慧公式热门

股票公式总点击榜

推荐股票公式